Connect with us:

Do I have v6?

If you want AAX, AU or VST support, you will need a v6 license.  To view what you have, follow the steps below.

1) Login to your iLok account using the iLok License Manager
2) If your McDSP license says:
Plugin name HD v6 or Native v6′ — Congrats, you’re already on v6!  You can use the latest installer from our Downloads page.
Plugin name HD’ — you need to upgrade to HD v6
Plugin name Native’ — you need to upgrade to Native v6
Plugin name LE’ — you need to upgrade from LE to Native v6
Plugin name Massive Pack’ — you need to upgrade to HD v6

Looking for a different upgrade path?  Send us an email at support@mcdsp.com that includes your iLok ID and we’ll help you.

HD/Native Specifications

HD v6: Full featured products. AAX DSP (32/64-bit), AAX Native (32/64-bit), Audiosuite, AU (64-bit), VST (64-bit) plug-in formats supported.

Native v6: Full featured products. AAX Native (32/64-bit), Audiosuite, AU (64-bit), VST (64-bit) plug-in formats supported. Complete session interchange with HD versions.

System Requirements

McDSP HD and Native plug-ins are compatible with Pro Tools, Pro Tools | HD, Logic 9 and Logic X, Cubase, Nuendo, Ableton Live, MOTU Digital Performer, Studio One, Sonar, and other DAWs that support AAX, AU, VST and/or VST3 plug-in formats.

McDSP Native plug-ins support AAX Native, AU, VST, and VST3 plug-in formats. McDSP HD plug-ins additionally support the AAX DSP plug-in format, as well as AAX Native, AU, VST, and VST3 plug-in formats. McDSP plug-ins support Mac OS 10.7.2 or later (Lion), 10.8.x (Mountain Lion), 10.9.x (Mavericks), 10.10.x (Yosemite), 10.11.x (El Capitan), and Windows 7, 8, and 10.

McDSP plug-ins require an iLok2 USB Smart Key for authorization.

McDSP AAX plug-ins require Windows 7 or later, Mac OS 10.7.2 or later, and support Pro Tools 10.3.8 or later, 11.1.3 or later, and Pro Tools 12.x or later.

McDSP AU plug-ins require Mac OS 10.7.2 or later, and support Logic 9 and Logic X, Digital Performer, Ableton Live, and other AU compatible DAWs.

McDSP VST and VST3 plug-ins require Windows 7 or later, Mac OS 10.7.2 or later, and support Cubase 7.x or later, Nuendo 6.5.x or later, and other VST and VST3 compatible DAWs.

Most McDSP HD plug-ins also support the VENUE systems on D-Show, Profile, and SC48 hardware. Exceptions are the 6020 Ultimate EQ, 6050 Ultimate Channel Strip, AE600 Active Equalizer, SA-2 Dialog Processor, and the SPC2000 Serial/Parallel compressor. These can only run on S3L and S6L systems.

Authorization

McDSP plug-ins require an iLok2 USB Smart Key for authorization. AAX, AU and VST plug-ins require the use of an iLok2.